Publi

Publi

Resultados 1 al 8 de 8


  1. #1
    Avatar de manusenda
    Erectus


    Reputación:
    Poder de reputación: 4

    Espana
    Mensajes: 131
    Créditos: 1,463

    Solución para "using of decompiled source code is prohibited"


    Publi
    Hola chicos, abro este hilo para preguntaros si alguno tiene un metaeditor pero en una versión más vieja.

    Lo necesito para compilar un ea, pero con las versiones actuales no puedo.

    Un saludo y gracias de antemano!


    EDITO: Solucionado, ver los siguientes mensajes.
    Foro de Forex Trading United
    Última edición por manusenda; 04-01-2014 a las 15:00 Razón: Solución

    <()>manusenda<()>

  2.                         
    Publi
  3. #2
    Avatar de Hermo
    Heidelbergensis


    Reputación:
    Poder de reputación: 11

    Mensajes: 858
    Créditos: 5,058

    Tenéis alguno el metaeditor?

    Cita Iniciado por manusenda Ver mensaje
    Hola chicos, abro este hilo para preguntaros si alguno tiene un metaeditor pero en una versión más vieja.

    Lo necesito para compilar un ea, pero con las versiones actuales no puedo.

    Un saludo y gracias de antemano!
    Buenas tarde manusenda:

    Yo no te puedo ayudar de la forma que tu pides, pero si adjuntas aqui la EA, trato de compilartela yo para que te sirva para las nuevas versiones de MT4-

    Un saludo

    Hermo.
    Foro de Forex Trading United

     

  4. #3
    Avatar de manusenda
    Erectus


    Reputación:
    Poder de reputación: 4

    Espana
    Mensajes: 131
    Créditos: 1,463

    Re: Tenéis alguno el metaeditor?

    Cita Iniciado por Hermo Ver mensaje
    Buenas tarde manusenda:

    Yo no te puedo ayudar de la forma que tu pides, pero si adjuntas aqui la EA, trato de compilartela yo para que te sirva para las nuevas versiones de MT4-

    Un saludo

    Hermo.

    La ea es un ex4 que destripe con el ex4_to_mq4 (el programa que subí hace poco en otro tema).

    El caso es que tengo ya el archivo mql4, pero a la hora de compilarlo te sale el típico error de "using of decompiled source code is prohibited". Debido a que el ea es de hace poco.

    La solución más fácil para esto es compilarlo con una versión mas vieja del metaeditor, pero ahora mismo no tengo ninguna.

    Vamos en verdad el ea que digo es lo de menos, sólo lo he hecho para mirar el código y verlo por dentro.

    Pero si me vendría bien el metaeditor para solucionar este problema para
    futuros eas.



    Bueno un saludo compañero y gracias!
    Foro de Forex Trading United

    <()>manusenda<()>

  5. #4
    Avatar de deckardbcn
    antecessor


    Reputación:
    Poder de reputación: 7

    Mensajes: 255
    Créditos: 288

    Re: Tenéis alguno el metaeditor?

    Hola manusenda.

    Quizá este hilo de otro foro te sirva...

    http://worldwide-invest.org/threads/...mpiled-sources

    Un saludo!
    Foro de Forex Trading United



    Para tener éxito como operador, hace falta coraje, el coraje de probar, el coraje de fallar, el coraje de tener éxito y el coraje de seguir adelante cuando las cosas se complican (MICHAEL MARCUS)



  6. #5
    Avatar de manusenda
    Erectus


    Reputación:
    Poder de reputación: 4

    Espana
    Mensajes: 131
    Créditos: 1,463

    Re: Tenéis alguno el metaeditor?

    Cita Iniciado por deckardbcn Ver mensaje
    Hola manusenda.

    Quizá este hilo de otro foro te sirva...

    http://worldwide-invest.org/threads/...mpiled-sources

    Un saludo!

    Muchas gracias compañero, era justo lo que necesitaba

    Un saludo!

    P.d: En el hilo proporcionado por deckardbcn podréis encontrar varias soluciones a este problema y varios metatrader en otras versiones más antiguas para poder compilar los eas para que no salga el error de "using descompile is prohibited"

    Iba a subir todos los que vienen en el hilo pero ocupan mucho y no me deja la página pero aquí os dejo una versión de metatrader de alpari v432

    MetaTrader 432 Alpari.part1.rar
    MetaTrader 432 Alpari.part2.rar

    Saludos!!
    Foro de Forex Trading United
    Última edición por manusenda; 04-01-2014 a las 15:15

    <()>manusenda<()>

  7. #6
    Avatar de Peyton
    Heidelbergensis


    Reputación:
    Poder de reputación: 14

    Mensajes: 2,356
    Créditos: 1,461

    Re: Tenéis alguno el metaeditor?

    Gracias. Podéis compartir algunas de esas soluciones para los compañeros que vengan después y que no sepan inglés? así este hilo quedaría muy completo para remitir a el cada vez que alguien pregunté lo mismo.

    saludos
    Foro de Forex Trading United




  8. #7
    Avatar de manusenda
    Erectus


    Reputación:
    Poder de reputación: 4

    Espana
    Mensajes: 131
    Créditos: 1,463

    Re: Tenéis alguno el metaeditor?

    Cita Iniciado por Peyton Ver mensaje
    Gracias. Podéis compartir algunas de esas soluciones para los compañeros que vengan después y que no sepan inglés? así este hilo quedaría muy completo para remitir a el cada vez que alguien pregunté lo mismo.

    saludos
    Vale de acuerdo voy a intentar explicar un poco esto:

    Este tema está destinado para aquellos que conseguís cualquier ea y sólo tenéis el archivo ex4 ( por lo que no podéis ver su parte interna ya que no tenéis el mql4 )

    Para hacer esto existen varios programas que suelen ser de pago, uno de ellos es el "ex4_to_mq4" que yo subí gratuitamente a este foro (lo volveré a poner en este tema)

    Este programa es muy fácil de usar básicamente le decís donde está el archivo ex4 y el os generará el mql4.

    El problema viene cuando le dais a compilar ese archivo mql4 y sale este error "using of decompiled source code is prohibited" (Esto significa que el editor del metatrader se ha dado cuenta que habéis descompilado el código y os salta este error)

    Muy bien ya explicado lo anterior vamos a las soluciones a dicho error:

    En los eas más viejos que no son muy reciente basta con hacer esto:

    1-cuando el programa genere el archivo mql4, en la parte de arriba os saldrá esto:


    /*
    Generated by EX4-TO-MQ4 decompiler FREEWARE V4.0.451.1 [-]
    Website: http://www.metaquotes.net
    E-mail : support@metaquotes.net
    */

    2-Lo borráis, y una vez borrado, copiáis todo el código(todo el texto del ea).

    3- En el meta-editor le dais a crear un nuevo ea, borráis todo lo que os salga y le dais a pegar lo que habíais copiado antes

    4-Guardáis el ea que habéis creado, lo compiláis y si lo habéis hecho bien no os debería de salir el error.


    Esta solución es la misma que la del punto 1 de Wolfman.

    Sino os funciona este método pasáis a las siguientes que ha explicado él.

    Que por lo que veo se me ha adelantado jajaj

    p.d: para los demás métodos usad el metatrader que he subido en mis anteriores mensajes, hay tenéis todo lo necesario.


    Aquí os dejo el "ex4 to mql4"

    Un Saludo!
    Foro de Forex Trading United
    Archivos adjuntados Archivos adjuntados
    Última edición por manusenda; 04-01-2014 a las 19:51

    <()>manusenda<()>

  9. #8
    Avatar de Wolfman
    Heidelbergensis


    Reputación:
    Poder de reputación: 15

    Mensajes: 2,052
    Créditos: 7,617

    Re: Tenéis alguno el metaeditor?


    Publi
    Cita Iniciado por Peyton Ver mensaje
    Gracias. Podéis compartir algunas de esas soluciones para los compañeros que vengan después y que no sepan inglés? así este hilo quedaría muy completo para remitir a el cada vez que alguien pregunté lo mismo.

    saludos
    Las que yo he utilizado y mer hasn funcionado hastas el momento son.

    1. Revisar el codigo interno del expert, normalmente en las primeras lineas menciona que se ha untilizado un decompilador, borrar esas lineas ya que solo son de informacion.

    2. Bajar el Expert a un mt4 anterior y compilarlo en el para luego pasarlo a un mt4 mas reciente.

    3. Copiar el archivo metalag de un mt4 anterior a la build 500, yo tengo la 432 y reemplazarlo en el mt4 que estas usando.

    Por el momento con eso he podido resolver espero les sirva.

    Saludos.
    Foro de Forex Trading United



    "La mente es como un paracaídas, sólo funciona si se abre. Albert Einstein

Publi
Publi


Aviso Legal
Ley Orgánica 15/1999, de 13 de diciembre, de Protección de Datos de Carácter Personal