Publi

Publi

Resultados 1 al 4 de 4


  1. #1

    ergaster


    Reputación:
    Poder de reputación: 2

    Espana
    Mensajes: 12
    Créditos: 212

    Ayuda con un EA


    Publi
    Hola.

    He encontrado este EA que parece bastante interesante, pero tengo un problema.


    Si hacéis un Backtest, da igual Divisas o Índices, veréis cómo al abrir una operación, automáticamente el sistema coloca Stop Loss y TP.


    Hasta ahí todo correcto.


    Pero al ponerlo a funcionar en vivo en una Cuenta Demo, pasa lo siguiente:


    En Divisas, al abrir una operación automáticamente, porque el sistema así lo considera, sí que marca automáticamente Stop Loss y TP


    Pero al hacerlo en Índices, con la misma configuración que en Divisas, al abrir una operación, NO me marca ni Stop Loss ni TP.


    Me he vuelto loco probando parámetros, cambiando Slippage, y nada. No hay forma.


    Pero ahora viene lo más curioso. Esto me pasa con mi Broker, Hanseatic BrokerHouse.


    Pero he probado una Cuenta Demo en GKFX y sí que marca los Stop Loss y TP tanto en Divisas como en Índices.

    La única diferencia que he visto en cuanto a Índices entre los dos Brokers, son los decimales.

    Es decir: Futuro DAX en Hanseatic cotiza a 10.329,50

    Y en GKFX el DAX cotiza a 10.329,8

    Hanseatic tiene 1 dígito más.


    En fin, me estoy volviendo loco con el tema y necesito de vuestra sabiduría.

    Para que hayan más cruces y comprobarlo, lo mejor es hacerlo en TF M5

    Luego otra pelea es ver si el EA es rentable o no, pero eso ya es otra historia.


    El archivo.ex4 debe estar en Asesores Expertos
    El archivo .mq4 en Indicadores

    Añado Foto con Error de Registro Metatrader.

    Como se puede apreciar aparece error al intentar marcar SL y TP con Índices con el servidor Hanseatic. Cosa que no pasa con Divisas ni con GKFX.

    Puede que el error sea porque el Broker solo admite decimales .00, .25, .50 y .75

    Cuando el EA intenta poner un SL o TP por ejemplo en el DAX en 10.356.16 ahí viene el fallo.

    A ver si alguien consigue iluminarme.

    Gracias.


    Edito: Añado archivo de Código Fuente. A ver si algún programador me puede ayudar.

    Gracias.
    Foro de Forex Trading United
    Miniaturas adjuntadas Miniaturas adjuntadas Ayuda con un EA-error-registro.jpg  
    Archivos adjuntados Archivos adjuntados
    Última edición por boxcar; 28-07-2016 a las 15:19 Razón: Añado código fuente

     

  2.                         
    Publi
  3. #2
    Avatar de robertomar
    Heidelbergensis


    Reputación:
    Poder de reputación: 9

    Espana
    Mensajes: 905
    Créditos: 15.929

    Re: Ayuda con un EA

    Cita Iniciado por boxcar Ver mensaje
    Hola.

    Puede que el error sea porque el Broker solo admite decimales .00, .25, .50 y .75

    Cuando el EA intenta poner un SL o TP por ejemplo en el DAX en 10.356.16 ahí viene el fallo.

    A ver si alguien consigue iluminarme.

    Gracias.

    Pues tú lo has dicho, compi. Por lo visto el EA NO ha tenido en cuenta el tamaño del tick (TickSize) para redondear los precios a múltiplos del mismo.

    Si el EA es antiguo, normalmente los EAs antiguos suelen estar hechos para Forex, ya que de hace 2 o 3 años para atrás prácticamente solo se negociaba Forex con MetaTrader, la moda de meter CFDs en los brokers de Forex viene de hace pocos años para acá. Y como en Forex normalmente el tamaño del tick siempre suele ser de 1 point (0.1 pips) pues no había problema y no hacía falta tener en cuenta este tipo de cosas.

    Se podría modificar para tenerlo en cuenta y que pudiese operar en brokers y activos con otro tick size, pero para ello tendrías que tener el archivo del código fuente (mq4) y no solo el ejecutable (ex4). Por lo que veo el mq4 que tienes parece ser un indicador, pero lo que es el EA solo colgaste el ex4.

    Saludos y un abrazo.
    Foro de Forex Trading United

  4. #3

    ergaster


    Reputación:
    Poder de reputación: 2

    Espana
    Mensajes: 12
    Créditos: 212

    Re: Ayuda con un EA

    Hola.

    Lo primero, muchas gracias por responder.

    Por lo menos ya sé dónde está el problema. Literalmente ha sido una locura ver por qué no funcionaba.

    Lo del código fuente no tengo ese archivo.

    El EA lo saqué del foro de Forexfactory y literalmente he acribillado a mensajes al tío que lo colgó. Pero pasa de mi. Jajajajaja

    Entonces la única solución que veo es cambiar de Broker.

    Saludos.
    Foro de Forex Trading United

     

  5. #4

    ergaster


    Reputación:
    Poder de reputación: 2

    Espana
    Mensajes: 12
    Créditos: 212

    Re: Ayuda con un EA


    Publi
    Añadido archivo de código fuente en el primer post

    ADX Bone 0.2.mq4
    Foro de Forex Trading United

     

Publi
Publi


Aviso Legal
Ley Orgánica 15/1999, de 13 de diciembre, de Protección de Datos de Carácter Personal