Publi

Publi

Resultados 1 al 4 de 4


  1. #1

    antecessor


    Reputación:
    Poder de reputación: 8

    Venezuela
    Mensajes: 597
    Créditos: 2,154

    problema generando codigo en EA Builder


    Publi
    Saludos.

    Estoy teniendo dificultades generando código mql4 con el EA Builder.

    Una vez que he realizado y validado el diagrama, selecciono la opción para generar el código. Y cuando le doy al botón de crear, me sale un mensaje de error, diciéndome que chequee en Metatrader setup, la opción verificar. Y allí me aparece un mensaje diciendo:

    "La configuracion del MetraTrader está mal. El directorio seleccionado no contiene los archivos MetaLang.exe (MT4 compiler) y MetaEditor.exe (MT4 editor). Alpari EA Builder necesita estos archivos para generar y compilar el Asesor Experto. Cambie el directorio MetaTrader al directorio donde se encuentra localizado MetaLang.exe".


    No he visto el archivo llamado MetaLang.exe; el MetaEditor si. Lo que he hecho es darle a la opción de "cambiar el directorio" en "MetaTrader Setup", y allí seleccionar la carpeta donde se ubica el archivo metaeditor. Sin embargo, al momento de darle a la opción de generar código, me sigue apareciendo el mismo problema.

    ¿Alguien sabe que se puede hacer para resolver esto?

    Muchas gracias de antemano
    trader201
    Foro de Forex Trading United

     

  2.                         
    Publi
  3. #2
    Avatar de tivag
    antecessor


    Reputación:
    Poder de reputación: 9

    Espana
    Mensajes: 610
    Créditos: 3,998

    Re: problema generando codigo en EA Builder

    Cita Iniciado por trader201 Ver mensaje
    Saludos.

    Estoy teniendo dificultades generando código mql4 con el EA Builder.

    Una vez que he realizado y validado el diagrama, selecciono la opción para generar el código. Y cuando le doy al botón de crear, me sale un mensaje de error, diciéndome que chequee en Metatrader setup, la opción verificar. Y allí me aparece un mensaje diciendo:

    "La configuracion del MetraTrader está mal. El directorio seleccionado no contiene los archivos MetaLang.exe (MT4 compiler) y MetaEditor.exe (MT4 editor). Alpari EA Builder necesita estos archivos para generar y compilar el Asesor Experto. Cambie el directorio MetaTrader al directorio donde se encuentra localizado MetaLang.exe".


    No he visto el archivo llamado MetaLang.exe; el MetaEditor si. Lo que he hecho es darle a la opción de "cambiar el directorio" en "MetaTrader Setup", y allí seleccionar la carpeta donde se ubica el archivo metaeditor. Sin embargo, al momento de darle a la opción de generar código, me sigue apareciendo el mismo problema.

    ¿Alguien sabe que se puede hacer para resolver esto?

    Muchas gracias de antemano
    trader201

    hola he buscado el archivo en la mt4 actualizada y no lo encuentro asi que imagino que lo abran quitado ... me imagino que ea builder tendra que solucionar ese problema con una nueva version del programa si eso mandales un correo a ver si ellos saben orientarte mejor, a mi lo unico que se me ocurre es que compiles con la version antigua y luego pasar el ea al nuevo mt4 copiandolo , otra opcion aunque no creo que sirva es que copies el archivo metalang a donde tienes instalado el nuevo mt4 a ver si asi.... imagino que no ira pero nunca se sabe jejej , si no lo tienes me avisas que te lo paso.



    saludos
    Foro de Forex Trading United

     

  4. #3




    Reputación:
    Poder de reputación: 4

    Mensajes: 1
    Créditos: 50

    Re: problema generando codigo en EA Builder

    yo tb tengo este problema acabo de descargarme la mt4 nueva y el ea builder y me da ese fallo, como lo habeis solucionado?
    Foro de Forex Trading United

     

  5. #4




    Reputación:
    Poder de reputación: 5

    Espana
    Mensajes: 59
    Créditos: 1,184

    Re: codigo mql4


    Publi
    hola,
    después de leer los temas me he decidido por colgar mi duda aquí, si no es el lugar, os pido que me disculpéis y me reenviéis al sitio adecuado.


    tengo un ea que parte del código es este,
    //+------------------------------------------------------------------+
    //| bar ckeck |
    //+------------------------------------------------------------------+
    bool isNewBar()
    {
    static datetime NewTime = 0;
    bool NewBar = false;
    if (NewTime != Time[0])
    {
    NewTime = Time[0];
    NewBar = true;
    }
    return (NewBar);
    }
    //+-------------------------------------

    Creo que es para que solo funcione con la apertura de vela, alguien me lo puede confirmar,
    y si es así, no debería darme los mimos resultados al hacer el backtest.

    si no es asi, alguien podria decirme que codigo y donde tendria que añadirlo, para que el ea funcione solo a la apertura de una nueva vela, gracias
    Foro de Forex Trading United

     

Publi
Publi


Aviso Legal
Ley Orgánica 15/1999, de 13 de diciembre, de Protección de Datos de Carácter Personal